the vista snipping tool (where is it?)

I went to use the vista screenshot tool just now and couldn’t find it. After some investigation I realized that the snipping tool is included with the “tablet pc components” in vista and w7. So if you uninstall things that aren’t needed (like the tablet pc components), then you won’t have this.

Why this is included with the “tablet pc components”? I have no idea. This doesn’t make any sense to me.

deleting a partition during the w7 install

I had an issue tonight when reinstalling w7 where the install would not let me delete the partitions on one of the disks… they could be formatted, etc, but the delete button was grayed out for some reason. Why it did this, I can’t tell you. What I finally found to fix it was this:

  • on the first welcome screen of the w7 install, hit shift-f10, this gives you a command prompt
  • run diskpart
  • list disks
  • select disk 0 (if this is the disk you want)
  • clean
  • exit

Then you can continue with the install on a new fresh and clean drive.

jusched.exe #fail

I really dislike this stupid java update scheduler already for a whole lot of reasons, but with windows 7 it’s an extra hassle, at least for me. This is because that new systray icons are hidden by default, so you can not notice the (stupid) thing running. Just now I started to use my laptop and realized it was very slow. Here’s why:

image

 

Total and complete #fail.

run a chkdsk under 2008r2 (or regular 2008, or w7), use all your memory

I run chkdsk.exe pretty often on my machines, mainly because I’m paranoid about data integrity since I have a lot of data spread across many hard drives. On my server I was trying to run chkdsk.exe on a couple of drives at once, thinking I could save myself some time.

chkdsk

When the machine slowed down to a crawl, I started by looking at the disk utilization to see what was going on. It was expected that this would slow down the machine, but these are non system disks, physically separate from anything that should directly impact system performance. After killing two of the three chkdsk’s, I was left with the one on the “J” drive, so I decided to check disk performance with the performance monitor.

pagefileusedchkdsk

Here you can see that aside from the chkdsk itself, there is some pretty significant writing taking place to the pagefile located on my “G” drive… Which shouldn’t take place since this machine has 8gb of ram and with no virtual machines running, never uses more than 1 gig. (No vm’s are running during all of this.) Of course, hitting the pagefile so much implies that the server is running out of memory, so let’s go see what the memory tab looks like.

chkdskuseallramyeah2

Here you can see that there is 0 free memory (as in zero)! Then you can look at the processes and see that chkdsk.exe is using 7.0 gigs of memory! What? This must be a bug.. a leak.. right? Something must be wrong. Well, guess what? Apparently this is by design… from what I have been able to gather after reading various forums and blogs, the w7/2008 server version of chkdsk will use all the available ram in an attempt to speed up the chkdsk.

Here’s a Microsoft article that mentions it.

Now there has been a lot of sky is falling type talk over this subject, and there are many people who have stated that their machines crashed as a result of this. To be clear in my case the machine does continue to function, although it does it very slowly. In my opinion, this behavior, even if by design, is very bug-like and mimics a memory leak in every way, just without the crash at the end. (And the memory clears up when chkdsk is done.) This seems like an odd way for Microsoft to design this, and I would prefer some other way to limit the ram used by this process.

compact fluorescent light bulb (cfl) failures – from Home Depot and Costco suck

 

I replaced all of the incandescent bulbs in my house about 2.5 years ago with CFL’s in an attempt to save energy and be “green”. Unfortunately, the burnout rate on the bulbs that Home Depot and Costco are selling aren’t just high.. they are so high that it makes these bulbs a total ripoff that costs you more money in the end.

Here’s a site with some reviews.

Similar model (not flood) with similar reviews.

These bulbs were also UNQUALIFIED from the energy star compliance list.

Here’s someone else with some failure info.

Here’s a good thread with pictures and some technical explanations.

More info on CFL failures.

making the SoundBlaster XFI actually work with an nforce4 motherboard

I have posted before about problems with the XFI and Nforce4 not working (with my Asus A8n-SLI Deluxe motherboard). Creative says it’s Nvidia’s fault, and Nvidia hasn’t really weighed in either way, but in the end the card just didn’t work, when you tried to play audio, you would get crackling and popping in the audio making it useless. The card was pretty much worthless to me at this point, but in my quest to be cheap, I kept trying and trying. Then the other day I ran across this modified driver and after installing this one… it works!

access denied in sharepoint 2007

I found a couple of strange problems sharepoint 2007.

  1. When you are trying to run a profile import against a domain, even if you set credentials explicitly, it will not work unless you log in with an account that has domain access. (This makes no sense..)
  2. Even though you are a site administrator, collection administrator, everything, when you click on “user profiles and properties” under your shared services ssp, you get an “access denied”. I found this fix that someone else posted.

this is just dumb (SMTP manager on 2008 server)

I had to install the SMTP service on a 2008 server today for the first time, and Microsoft does not make it easy.

  1. The SMTP install is under features and not under roles.
  2. When you do install SMTP, where do you manage it, you wonder. Thanks to google and this link, I now know that you have to use the IIS6 manager. What??!!

Tankless water heater: I tried

I recently learned thought I learned that my water heater had gone south. This was expected, due to its 13 years of age and II had found rust in my water. Since I consider myself smart enough to look at the long term benefits of something, even if the initial cost is greater, I decided to look into a tankless water heater. Research showed that they were supposed to save anywhere from 15%  to 40% on your gas bill every month, last longer, etc. You also get a tax break and a credit from your local energy company (in most cases) so it seemed like a no brainer. Aside from the initial cost being greater, the advantages looked great.

After some research, I found out what size I needed, and they they seemed to pretty much all have the same features and prices, so I went to lowes and picked up a Bosch 2400 (only because I had a 10% off coupon).  Since I’m pretty handy around the house (I will not pay someone else to do something I can do on my own) I decided that with some help from my brother, we could install this thing no problem.

As far as location goes, the choices were small.. it pretty much had to go where the old tank water heater went, because that is where the piping is. There was some discussion about mounting it on the outside wall, but that would have made for about 25′ of extra pipe, and that didn’t seem like a good way to get water to the facts quickly.  Also, these things reqire large amounts of gas, in my house it worked out where all I needed to replace was about 1′ of pipe and a couple of fittings. This was pretty easy. What wasn’t so great was the flexible gas line that I needed, it was $70! Then a valve, and an adapter. The install was complicated in the fact that the hose that Lowes sells to go with the gas valve, didn’t have the right sized fitting to work on the water heater… and… they don’t stock it! So, in order to make this work, I had to go to Home Depot as well. (What?)

Before I bought the thing I did some research and found out that tankless heaters require updated exhaust venting, but I couldn’t found out too many of the details around it. After some reading online and scanning through the manual, it looked like what was needed was just dual walled exhaust pipe, which is code (almost?) everywhere now, and since this is what my house already had, we got the stuff to tie into my regular exhaust vent. We even found  a couple of write-ups online (I will look later and link them if I can) where others had done this. After reading the manually carefully though, and after a call to the Bosch 800#, I realized that in order to meet code, I would have to use the stuff that the manufacturer recommends, which is a stainless pipe that is sealed with a gasket. So.. I go back to lowes and get their install kit, which is $230 and includes about 4′ total of pipe. In order to get to the side of my house, I would need about 12′ of straight pipe in addition to this stuff. This was going out the side of the house instead of from the basement through the roof like the old exhaust vent ran since I also found out that the water heater can’t share an exhaust vent, it must have its very own. The pipe is special order at Lowes (and Home Depot for their brand I found out), so I went looking locally at the plumbing supply houses. In the end I learned that the exhaust pipe is mostly brand specific, and that no one carried anything locally. After some looking online again, I found the pipe for a price of $50 for a 4′ section online! This means that venting to the closest place I could, I would be out about $400 total. Ouch.

In the interim, I installed the unit and vented it to my existing exhaust pipe, while I waited on the ordering and shipping process to take place. So… we had hot water! ..and I went to take a very much needed shower. While showering, the water kept getting hotter and hotter, and while I was all soapy, the water got very cold, there was no hot water! After fuming about it for several minutes and rinsing off in cold water, the water came back hot again. What?! The next day I called Bosch and they told me that the temperature was adjusted too high, and what was happening was that I would turn the hot water so low during the shower because the temp was so high, that it would fall below the minumum flow rate needed to make hot water, so the heater would stop. Their answer was to turn the temperature down, which I did, and it didn’t help. Turning on a hot water faucet in a sink temporarily relieved the problem though, since it kept the flow rate up enough, and everything worked.

I troubleshooted it a bit and finally realized that the heater was making water that was 145 degrees, no matter what the setting… it was a bad heater. Great! So I did some more research and found out that Bosch isn’t one of the best brands out there, and lots of people had problems. Strangely enough, I didn’t see this beforehand. So off I went to Home Depot to buy their tankless product instead, I had it on the cart and was getting ready to leave when I realized that it required 4″ exhaust piping instead of 3″… meaning that I would have to buy 4″ pipe and adapt that to the 3″ pipe which was already in my house, and it was then that I decided this wasn’t meant to be. This was just too much trouble.

Sooo.. I put the Rheem from Home Depot back on the shelf and got one of HD’s GE water heaters, it was the best one, 12 year warranty, supposedly energy efficient, and I got a 50 gallon instead of a 40 gallon. Got home and started comparing the little yellow stickers and realized that the efficiency rating on my old water heater was .57, and the new, top of the line one I had just bought was… drumroll… .58. That’s right, 13 years later and .01 more efficient. Then I picked up the phone and called Lowes, and they had one with a .62 rating, and I decided I may as well get one as efficient as I can, and back to Home Depot I went to return the tank heater, and back to Lowes I went to purchase their tank product. (They must have thought I was crazy.)

In the end it took me about 2 hours to mount up the new tank water heater. It is a Whirlpool Energy Smart. I had hot water in about 30 minutes, it is working great, and I haven’t looked back. Lowes was nice about returning the tank heater and various bits and pieces. In the end with all the returns and whatnot (some of the stuff I couldn’t return), my new water heater cost me $908. My hope is that this one works out. If I had just gone with the tank heater in the beginning, I am sure I would have saved myself time and money, probably a couple hundred dollars at least.

Oh well, lesson learned.